aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gflags
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2016-08-11 12:10:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:32:01 +0200
commit32e7012ebdc956a5f5fc9622c6c6a72cd3ceaea1 (patch)
treec34a9acc623a4cf216f4b897c81400e556fd9d9b /meta-oe/recipes-support/gflags
parent6752cba478ab25b96f4183d3513fc1f171d31927 (diff)
downloadmeta-openembedded-contrib-32e7012ebdc956a5f5fc9622c6c6a72cd3ceaea1.tar.gz
gflags: New recipe
C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used. Used optionally by glog Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gflags')
-rw-r--r--meta-oe/recipes-support/gflags/gflags_2.1.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gflags/gflags_2.1.2.bb b/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
new file mode 100644
index 0000000000..b5e0597989
--- /dev/null
+++ b/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used"
+
+HOMEPAGE = "https://github.com/gflags/gflags"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
+
+SRC_URI = "git://github.com/gflags/gflags.git;branch=release"
+SRCREV = "1a02f2851ee3d48d32d2c8f4d8f390a0bc25565c"
+S = "${WORKDIR}/git/"
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+inherit cmake
+
+EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON"
+
+PACKAGES =+ "${PN}-bash-completion"
+FILES_${PN}-bash-completion += "${bindir}/gflags_completions.sh"
+RDEPENDS_${PN}-bash-completion = "bash-completion"