aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gnulib
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-30 12:26:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:49:35 +0100
commit2891b1654d81147344364093dc823d57a862ef80 (patch)
tree1f782fa8eca05ded104dab6bd1975569d00409d1 /meta-oe/recipes-support/gnulib
parent165de549b7a80a3a93c5ab1cc54b197101ffd2cf (diff)
downloadmeta-openembedded-contrib-2891b1654d81147344364093dc823d57a862ef80.tar.gz
gnulib: move meta-networking -> meta-oe
A more common place is required for gnulib because of other recipes (e.g fontforge) will depend on it Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-support/gnulib')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_git.bb b/meta-oe/recipes-support/gnulib/gnulib_git.bb
new file mode 100644
index 0000000000..a06450261c
--- /dev/null
+++ b/meta-oe/recipes-support/gnulib/gnulib_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "The GNU portability library"
+DESCRIPTION = "A collection of software subroutines which are designed to \
+be usable on many operating systems. The goal of the project \
+is to make it easy for free software authors to make their \
+software run on many operating systems. Since source is designed \
+to be copied from gnulib, it is not a library per-se, as much \
+as a collection of portable idioms to be used in other projects."
+
+HOMEPAGE = "http://www.gnu.org/software/gnulib/"
+SECTION = "devel"
+LICENSE = "LGPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=e4cf3810f33a067ea7ccd2cd889fed21"
+SRCREV = "24379a9217fa4bd62685795aaaa010fd90ced9e3"
+SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
+"
+S = "${WORKDIR}/git"
+
+do_install () {
+ cd ${S}
+ git checkout master
+ git clone ${S} ${D}/${datadir}/gnulib
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_package[noexec] = "1"
+do_packagedata[noexec] = "1"
+do_package_write_ipk[noexec] = "1"
+do_package_write_deb[noexec] = "1"
+do_package_write_rpm[noexec] = "1"