aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
diff options
context:
space:
mode:
authorBruno Bottazzini <bruno.bottazzini@intel.com>2016-04-27 13:26:48 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:38:33 +0200
commitc22af995a3150da62a5842efc352e45f55e41cd5 (patch)
tree594beb684b0bdf01ca59838d3e6a80df7afa3dc4 /meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
parentc16b6e686baf844d808cc2fefbff93357a51f2df (diff)
downloadmeta-openembedded-contrib-c22af995a3150da62a5842efc352e45f55e41cd5.tar.gz
libmicrohttpd: update to 0.9.49
This patch removes the flag --disable-spdy since libmicrospdy was dropped from libmicrohttpd as it is possible to see in the following commit. Revision: 36708 ID:36708 140774ce-b5e7-0310-ab8b-a85725594a96 URL: https://gnunet.org/svn/libmicrohttpd Signed-off-by: Bruno Bottazzini <bruno.bottazzini@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb')
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
new file mode 100644
index 0000000000..9abb2004e6
--- /dev/null
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.49.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
+HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
+LICENSE = "LGPL-2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
+SECTION = "net"
+DEPENDS = "libgcrypt gnutls file"
+
+SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "3209aa2ac6199b874a6325342b86edbc"
+SRC_URI[sha256sum] = "9407d8252548ab97ace3276e0032f073820073c0599d43baff832902a8dab11c"
+
+inherit autotools lib_package pkgconfig
+
+EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
+
+PACKAGECONFIG ?= "curl"
+PACKAGECONFIG_append_class-target = "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
+"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
+
+do_compile_append() {
+ sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
+}