aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libtinyxml
diff options
context:
space:
mode:
authorStefan Herbrechtsmeier <stefan@herbrechtsmeier.net>2013-03-14 16:45:57 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-18 16:31:32 +0100
commit19eb91d66d5ec899a781a14f3b9b50469d741d89 (patch)
tree760b1f3220304ee8cb1d61c86ba65af3973faad5 /meta-oe/recipes-support/libtinyxml
parentf841ddbd24d6c8b0befaf1b61bf6a5b3c777612c (diff)
downloadmeta-openembedded-contrib-19eb91d66d5ec899a781a14f3b9b50469d741d89.tar.gz
libtinyxml: Add native support and use relative paths
Replace CXXFLAGS += "-fPIC" with EXTRA_CXXFLAGS to allow native build and use relative paths to simplify recipe. Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libtinyxml')
-rw-r--r--meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
index fdadebdfa9..8670facc8f 100644
--- a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
+++ b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
@@ -16,20 +16,21 @@ SRC_URI[sha256sum] = "15bdfdcec58a7da30adc87ac2b078e4417dbe5392f3afb719f9ba6d062
S = "${WORKDIR}/tinyxml"
-CXXFLAGS += "-fPIC"
+EXTRA_CXXFLAGS = "-I. -fPIC"
do_compile() {
- ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxml.o ${S}/tinyxml.cpp
- ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxmlerror.o ${S}/tinyxmlerror.cpp
- ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxmlparser.o ${S}/tinyxmlparser.cpp
+ ${CXX} ${CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o tinyxml.o tinyxml.cpp
+ ${CXX} ${CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o tinyxmlerror.o tinyxmlerror.cpp
+ ${CXX} ${CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o tinyxmlparser.o tinyxmlparser.cpp
${CXX} ${CXXFLAGS} \
-shared \
-Wl,-soname,libtinyxml.so.${PV} \
- -o ${S}/libtinyxml.so.${PV} \
+ -o libtinyxml.so.${PV} \
${LDFLAGS} \
- ${S}/tinyxml.o \
- ${S}/tinyxmlparser.o \
- ${S}/tinyxmlerror.o
+ tinyxml.o \
+ tinyxmlparser.o \
+ tinyxmlerror.o
+
}
do_install() {
@@ -41,3 +42,4 @@ do_install() {
install -m 0644 ${S}/tinyxml.h ${D}${includedir}
}
+BBCLASSEXTEND += "native"