aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lzip/lzip_1.16.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-03 01:25:44 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 10:56:25 +0000
commitc0f0580287fb3551630f23bf43c4fc8db0100049 (patch)
tree1dfcd3364395cc8dd63c02ec0bb5648a64db26d1 /meta-oe/recipes-support/lzip/lzip_1.16.bb
parent74be454aeded97b7034f6bce3ee60af2cc8f60c3 (diff)
downloadmeta-openembedded-contrib-c0f0580287fb3551630f23bf43c4fc8db0100049.tar.gz
lzip: update to 1.16
* License changed to GPLv2+ * Trim SUMMARY * gz file is definitely being provided for download upstream, so drop comment saying it isn't Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support/lzip/lzip_1.16.bb')
-rw-r--r--meta-oe/recipes-support/lzip/lzip_1.16.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lzip/lzip_1.16.bb b/meta-oe/recipes-support/lzip/lzip_1.16.bb
new file mode 100644
index 0000000000..af0b6ae8e6
--- /dev/null
+++ b/meta-oe/recipes-support/lzip/lzip_1.16.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Lossless data compressor based on the LZMA algorithm"
+HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
+SECTION = "console/utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
+ file://decoder.cc;endline=16;md5=0809128ac32163252846e09a70c8b80b"
+
+SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "716a9876dc595ec52d4f3bda81e42471"
+SRC_URI[sha256sum] = "128cc25baf92c8b69700831e6f984d954016318cc78edca87870d0c033112751"
+
+CONFIGUREOPTS = "\
+ '--srcdir=${S}' \
+ '--prefix=${prefix}' \
+ '--exec-prefix=${exec_prefix}' \
+ '--bindir=${bindir}' \
+ '--datadir=${datadir}' \
+ '--infodir=${infodir}' \
+ '--sysconfdir=${sysconfdir}' \
+ 'CXX=${CXX}' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+B = "${S}/obj"
+do_configure () {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ # Info dir listing isn't interesting at this point so remove it if it exists.
+ if [ -e "${D}${infodir}/dir" ]; then
+ rm -f ${D}${infodir}/dir
+ fi
+}
+
+BBCLASSEXTEND += "native nativesdk"