aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-22 10:45:55 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-23 08:37:08 +0100
commit5b427f6daae0caa7439256ecf35a877f1cb2dbed (patch)
treecc7a5990a25daef925686ed95a7df3d08856885c /meta-oe/recipes-support/mysql
parentc6fe627660a6085f9377337f486e11bad92082e4 (diff)
downloadmeta-openembedded-contrib-5b427f6daae0caa7439256ecf35a877f1cb2dbed.tar.gz
mysql: make it work after $libexec change - LP: #1068759
Mysql start scripts assumed that mysqld is in /usr/libexec/ directory. It was true until 406bd38b4232f9f399ef5ffe0b4fac72ed605a23 landed in OE-Core. This changeset fixes mysqld start and initial databases population scripts. More: https://bugs.launchpad.net/linaro-oe/+bug/1068759 Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/mysql')
-rw-r--r--meta-oe/recipes-support/mysql/mysql5_5.1.40.inc10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/mysql/mysql5_5.1.40.inc b/meta-oe/recipes-support/mysql/mysql5_5.1.40.inc
index 3867a12467..af0ddbb5c0 100644
--- a/meta-oe/recipes-support/mysql/mysql5_5.1.40.inc
+++ b/meta-oe/recipes-support/mysql/mysql5_5.1.40.inc
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=477ab0a4c8ca64b482b3f2a365d0fdfa"
DEPENDS = "ncurses"
-PR = "r10"
+PR = "r11"
SRC_URI = "http://downloads.mysql.com/archives/mysql-5.1/mysql-${PV}.tar.gz \
file://configure.in.patch \
@@ -13,7 +13,7 @@ SRC_URI = "http://downloads.mysql.com/archives/mysql-5.1/mysql-${PV}.tar.gz \
file://misc.m4.patch \
file://Makefile.am.patch \
file://fix_host_path.patch \
- file://configure-ps-cache-check.patch \
+ file://configure-ps-cache-check.patch \
file://fix-abi-check-gcc45.patch \
file://my.cnf \
file://mysqld.sh"
@@ -36,6 +36,12 @@ EXTRA_OECONF = " --with-atomic-ops=up --with-embedded-server --prefix=/usr --sys
do_configure_append() {
sed -i /comp_err/d ${S}/sql/share/Makefile
+
+ # handle distros with different values of ${libexecdir}
+ libexecdir2=`echo ${libexecdir} | sed -e 's+/usr/++g'`
+ sed -i -e "s:/libexec:/$libexecdir2:g" ${S}/scripts/mysql_install_db.sh
+ sed -i -e "s:mysqld libexec:mysqld $libexecdir2:g" ${S}/scripts/mysql_install_db.sh
+ sed -i -e "s:/libexec:/$libexecdir2:g" ${S}/scripts/mysqld_safe.sh
}
SYSROOT_PREPROCESS_FUNCS += "mysql5_sysroot_preprocess"