aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ode/ode_0.13.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-02-24 13:59:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-05 18:38:39 +0100
commit3349d31304790b4122886c4843ef3ee9e20c9191 (patch)
treee3e160e58a16220332375c064d8190852e64f850 /meta-oe/recipes-support/ode/ode_0.13.bb
parent840a60cb1d41199c57d87e820abd88b40c7c8ae4 (diff)
downloadmeta-openembedded-contrib-3349d31304790b4122886c4843ef3ee9e20c9191.tar.gz
ode: upgrade to 0.13
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/ode/ode_0.13.bb')
-rw-r--r--meta-oe/recipes-support/ode/ode_0.13.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ode/ode_0.13.bb b/meta-oe/recipes-support/ode/ode_0.13.bb
new file mode 100644
index 0000000000..8e9eb153c2
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode_0.13.bb
@@ -0,0 +1,27 @@
+SUMMARY = "ODE is an Open Source Physics Engine"
+SECTION = "libs"
+HOMEPAGE = "http://www.ode.org"
+LICENSE = "LGPLv2.1 & BSD"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=1de906ee96808d9776dd72a5f9a79a22 \
+ file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff \
+"
+# LICENSE-BSD.TXT is missing in 0.13 tarball, but COPYING still says it's dual licensed
+# and svn repo still contains LICENSE-BSD.TXT so maybe it will return in next tarball
+# file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tar.bz2"
+SRC_URI[md5sum] = "04b32c9645c147e18caff7a597a19f84"
+SRC_URI[sha256sum] = "34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--disable-demos --enable-soname"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+
+PACKAGECONFIG ?= ""
+# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
+# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
+PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"