aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv_3.1.bb
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2016-08-05 18:38:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:57 +0200
commit886a5da6ac086cf0bf465609ee3b2f4fd177a007 (patch)
tree9d64e5c71577905a880ab2642341e7f2440422b9 /meta-oe/recipes-support/opencv/opencv_3.1.bb
parent2e0332ce3c86bfae9c69a3d434767d5a31fa8053 (diff)
downloadmeta-openembedded-contrib-886a5da6ac086cf0bf465609ee3b2f4fd177a007.tar.gz
opencv: Fix build with gcc 6.0
It seems like gcc 6.0 does not have the same behaviour as previous 5.x with regards isystem flag. Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv_3.1.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index c41baec7bb..8ab9a2b4e0 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -22,6 +22,7 @@ SRC_URI = "git://github.com/Itseez/opencv.git;name=opencv \
git://github.com/Itseez/opencv_contrib.git;destsuffix=contrib;name=contrib \
git://github.com/Itseez/opencv_3rdparty.git;branch=ippicv/master_20151201;destsuffix=party3;name=party3 \
file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
+ file://fixgcc60.patch \
file://fixpkgconfig.patch"
PV = "3.1+git${SRCPV}"
@@ -145,6 +146,3 @@ do_install_append() {
install -d ${D}${datadir}/OpenCV/samples/bin/
cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
}
-
-# http://errors.yoctoproject.org/Errors/Details/68617/
-PNBLACKLIST[opencv] ?= "BROKEN: fails to build with gcc-6"