aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/p910nd/p910nd_0.95.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-05-03 13:25:26 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-10 08:55:54 +0200
commiteea34cae84b89a418e0a23c4c8d68e951ba81130 (patch)
treeae40d5bd78f704bf80463620aaa079707fb48e00 /meta-oe/recipes-support/p910nd/p910nd_0.95.bb
parent5121fb29b5a26ab02d2f5a6038b6abbf51bc338d (diff)
downloadmeta-openembedded-contrib-eea34cae84b89a418e0a23c4c8d68e951ba81130.tar.gz
p910nd: add version 0.95
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-oe/recipes-support/p910nd/p910nd_0.95.bb')
-rw-r--r--meta-oe/recipes-support/p910nd/p910nd_0.95.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/p910nd/p910nd_0.95.bb b/meta-oe/recipes-support/p910nd/p910nd_0.95.bb
new file mode 100644
index 0000000000..ee43a595d7
--- /dev/null
+++ b/meta-oe/recipes-support/p910nd/p910nd_0.95.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A small network printer daemon for embedded situations that passes the job directly to the printer"
+HOMEPAGE = "http://p910nd.sourceforge.net/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+
+PR = "r0"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "p910nd"
+INITSCRIPT_PARAMS = "defaults 60 "
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/p910nd/p910nd-${PV}.tar.bz2 \
+ file://p910nd.init"
+
+SRC_URI[md5sum] = "c7ac6afdf7730ac8387a8e87198d4491"
+SRC_URI[sha256sum] = "7d78642c86dc247fbdef1ff85c56629dcdc6b2a457c786420299e284fffcb029"
+
+do_compile () {
+ ${CC} ${LDFLAGS} -o p910nd p910nd.c
+}
+
+# The avahi stuff makes it work with bonjour printing
+do_install () {
+ install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd
+ install -D -m 0644 ${S}/p910nd.conf ${D}${sysconfdir}/p910nd.conf
+ install -D -m 0755 ${WORKDIR}/p910nd.init ${D}${sysconfdir}/init.d/p910nd
+}