aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin
diff options
context:
space:
mode:
authorJakob Drexel <jake42@rommel.stw.uni-erlangen.de>2014-01-13 19:31:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:36 +0100
commit31716a11cdf814b15552b441498cf32b76759ebf (patch)
treee4050eb1cdff63c37075d8f546fb8dedd3e0b306 /meta-oe/recipes-support/pidgin
parente021ccee741e406cacba8f30d92c3161e64eb17d (diff)
downloadmeta-openembedded-contrib-31716a11cdf814b15552b441498cf32b76759ebf.tar.gz
pidgin: Add pidgin-otr recipe and a patch for it
Also added a patch to fix issue with autotools. Signed-off-by: Jakob Drexel <jake42@rommel.stw.uni-erlangen.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pidgin')
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin-otr/ignore_extra-portability_warnings.patch19
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin-otr_4.0.0.bb19
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin-otr/ignore_extra-portability_warnings.patch b/meta-oe/recipes-support/pidgin/pidgin-otr/ignore_extra-portability_warnings.patch
new file mode 100644
index 0000000000..db0ad873b0
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/pidgin-otr/ignore_extra-portability_warnings.patch
@@ -0,0 +1,19 @@
+pidgin-otr: Silence no-extra-portability warnings
+
+Make it build with OE, was not building with warning turned on
+
+Upstream-Status: Pending
+
+Signed-off-by: Jakob Drexel <jake42@rommel.stw.uni-erlangen.de>
+
+--- a/configure.ac 2012-09-01 17:03:19.000000000 +0200
++++ b/configure.ac 2014-01-12 21:59:24.920300215 +0100
+@@ -4,7 +4,7 @@
+
+ AM_CONFIG_HEADER(config.h)
+
+-AM_INIT_AUTOMAKE([-Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall -Werror -Wno-extra-portability])
+
+ AC_PROG_CC
+
diff --git a/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.0.bb b/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.0.bb
new file mode 100644
index 0000000000..93139b98d2
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/pidgin-otr_4.0.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE = "http://www.cypherpunks.ca/otr/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=92fe174bad6da3763f6e9e9eaff6df24"
+DEPENDS = "libgcrypt libotr pidgin"
+
+SRC_URI = "http://www.cypherpunks.ca/otr/${P}.tar.gz \
+ file://ignore_extra-portability_warnings.patch \
+"
+
+SRC_URI[md5sum] = "eadb953376acc474e56041d4c12aa2c8"
+SRC_URI[sha256sum] = "d56b3f092dbe9ee6597641c7d2dd294884dc04ba47aaf4ec571cd54977df4691"
+
+
+FILES_${PN} = "${libdir}/pidgin/*"
+FILES_${PN}-dbg = "${libdir}/pidgin/.debug"
+FILES_${PN}-dbg += "${libdir}/pidgin/.debug/pidgin-otr.so"
+FILES_${PN}-dbg += "/usr/src/debug/pidgin-otr/${PV}-${PR}/${P}/*"
+inherit autotools pkgconfig