aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/postgresql
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2015-11-12 12:35:36 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:42:08 +0100
commitb2bf995c4e68f0eb434549ed512e06313fa67881 (patch)
tree61e89f2bfbea2b75861b6760736524c01b7b9d9f /meta-oe/recipes-support/postgresql
parent49e6d6103e35e1646674c6fd7e70c387b1b127b4 (diff)
downloadmeta-openembedded-contrib-b2bf995c4e68f0eb434549ed512e06313fa67881.tar.gz
postgresql: Don't symlink to perl if it's disabled
Don't create a symlink to libperl.so if perl isn't in PACKAGECONFIG. Attempting to do so will fail if perl hasn't been built. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/postgresql')
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index f3ff22583a..dbc02a0134 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -141,14 +141,16 @@ do_configure() {
-e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \
${B}/src/Makefile.global
- # workaround perl package's libperl.so problem
- # we are using perlnative so this perl should have same version
- perl_version=`perl -v 2>/dev/null | \
- sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
- if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
- ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
- ln -sf ../../../libperl.so.5 \
- ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
+ if ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'true', 'false', d)}; then
+ # workaround perl package's libperl.so problem
+ # we are using perlnative so this perl should have same version
+ perl_version=`perl -v 2>/dev/null | \
+ sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
+ if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
+ ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
+ ln -sf ../../../libperl.so.5 \
+ ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
+ fi
fi
}