aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2013-09-13 20:08:22 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-19 13:56:28 +0200
commit7be78a939bde5228a7f92a58ac08dd10901a8a4f (patch)
tree6c728c4f6f4c4c47e61f7f820c860da9f7e86fb8 /meta-oe/recipes-support/vim
parent3000970fcd979ac2d68ef406778dbc4da86da73f (diff)
downloadmeta-openembedded-contrib-7be78a939bde5228a7f92a58ac08dd10901a8a4f.tar.gz
vim: upgrade to v7.4.27 and refactor
'vim.inc' is merged into the new recipe 'vim_7.4.27.bb', the recipe is slightly reorganised and a minor omission in the comments is corrected. DESCRIPTION is replaced with SUMMARY. PR and INC_PR values are dropped. The variable PV_MAJOR is also dropped as it isn't used. LIC_FILES_CHECKSUM is updated as an address and version number given in the license have been modified. The main license text itself is unchanged. The setting of PARALLEL_MAKE to force single-threaded compilation is removed as there is no justification in the git history for this being needed and the compilation completes fine without it. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r--meta-oe/recipes-support/vim/vim_7.3.1314.bb7
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.27.bb (renamed from meta-oe/recipes-support/vim/vim.inc)19
2 files changed, 8 insertions, 18 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.3.1314.bb b/meta-oe/recipes-support/vim/vim_7.3.1314.bb
deleted file mode 100644
index 1be5a91022..0000000000
--- a/meta-oe/recipes-support/vim/vim_7.3.1314.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require ${PN}.inc
-
-PR = "${INC_PR}.0"
-
-SRCREV = "v7-3-1314"
-
-SRC_URI += "file://configure.in_remove_CC_quotes.patch;patchdir=.."
diff --git a/meta-oe/recipes-support/vim/vim.inc b/meta-oe/recipes-support/vim/vim_7.4.27.bb
index 991ba74f12..77507d4c59 100644
--- a/meta-oe/recipes-support/vim/vim.inc
+++ b/meta-oe/recipes-support/vim/vim_7.4.27.bb
@@ -1,20 +1,19 @@
-DESCRIPTION = "Vi IMproved - enhanced vi editor"
+SUMMARY = "Vi IMproved - enhanced vi editor"
SECTION = "console/utils"
DEPENDS = "ncurses"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=4c91d841bb7b75f68b5bb8ad7118f5b8"
+LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8"
-PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
-VIMDIR = "${PN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}"
-
-INC_PR = "r13"
-
-SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim"
+SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \
+ file://configure.in_remove_CC_quotes.patch;patchdir=.."
+SRCREV = "v7-4-027"
S = "${WORKDIR}/${PN}/src"
+VIMDIR = "${PN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}"
+
inherit autotools update-alternatives
# vim configure.in contains functions which got 'dropped' by autotools.bbclass
@@ -28,7 +27,7 @@ do_configure () {
touch auto/config.mk auto/config.h
}
-#Available PACKAGECONFIG options are gtkgui, x11, tiny
+#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
PACKAGECONFIG ??= ""
PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+,"
@@ -76,5 +75,3 @@ ALTERNATIVE_${PN} = "vi"
ALTERNATIVE_TARGET[vi] = "${bindir}/${PN}"
ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi"
ALTERNATIVE_PRIORITY[vi] = "100"
-
-PARALLEL_MAKE = ""