aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xdelta
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-05-12 12:00:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-15 12:30:19 +0200
commit228119cb3e06460192035966b18d3c24c3d0f3d9 (patch)
tree6cf89b9caa66e9e254048c2bd57a07f1112d3271 /meta-oe/recipes-support/xdelta
parentde87d83a642d720d8330808978d4cf0ea3c22d96 (diff)
downloadmeta-openembedded-contrib-228119cb3e06460192035966b18d3c24c3d0f3d9.tar.gz
xdelta3: add optional lzma support
Using PACKAGECONFIG. Disabled by default. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xdelta')
-rw-r--r--meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch55
-rw-r--r--meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb8
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch
new file mode 100644
index 0000000000..4b99290d2d
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch
@@ -0,0 +1,55 @@
+Upstream-Status: Pending, Submitted
+http://code.google.com/p/xdelta/issues/detail?id=178
+
+xdelta3: add --with-liblzma configure option
+
+As xdelta3 can be compiled with or without liblzma external library, make it configurable.
+Default is autodetect (unchanged behavior).
+
+Signed-off-by: Matthieu Crapet <mcrapet@gmail.com>
+---
+ configure.ac | 21 +++++++++++++++++++--
+ 1 file changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3b430d7..8c53ba8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,8 +8,6 @@ AM_INIT_AUTOMAKE([1.9 no-define foreign tar-ustar])
+ AX_CHECK_ALIGNED_ACCESS_REQUIRED
+ AC_PROG_CC
+ AC_PROG_CXX
+-AC_CHECK_HEADERS([lzma.h])
+-AC_CHECK_LIB(lzma, lzma_easy_buffer_encode)
+ AC_CHECK_SIZEOF(size_t)
+ #AM_PATH_PYTHON(,, [:])
+ #AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
+@@ -22,6 +20,25 @@ AC_ARG_ENABLE(debug-symbols,
+ AS_HELP_STRING(--enable-debug-symbols,[Build with debug symbols (default is NO)]),,enableval=no)
+ AM_CONDITIONAL([DEBUG_SYMBOLS], [test ${enableval} = "yes"])
+
++AC_ARG_WITH(
++ [liblzma],
++ [AC_HELP_STRING(
++ [--with-liblzma],
++ [build with liblzma support @<:@default=autodetect@:>@])],
++ [USE_LIBLZMA=$withval],
++ [USE_LIBLZMA=auto])
++
++if test "x$USE_LIBLZMA" != xno ; then
++ AC_CHECK_HEADERS([lzma.h],,[
++ if test "x$with_liblzma" = xyes ; then
++ AC_MSG_FAILURE([liblzma includes was not found])
++ fi])
++ AC_CHECK_LIB([lzma], [lzma_easy_buffer_encode],,[
++ if test "x$with_liblzma" = xyes ; then
++ AC_MSG_FAILURE([liblzma library was not found])
++ fi])
++fi
++
+ AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
+--
+1.8.5.4
+
diff --git a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
index 16a72ee8ee..baa92e4bb2 100644
--- a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
+++ b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
@@ -8,8 +8,14 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \
- file://compilation-fix.patch"
+ file://compilation-fix.patch \
+ file://with-liblzma-configure-option.patch \
+"
SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3"
SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55"
inherit autotools
+
+# Optional secondary compression
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz"