aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/zstd/zstd_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-10-02 15:17:41 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-10-19 09:31:26 +1300
commitd6f699c1268947a2298f01af26f384c4465b633a (patch)
tree8a3332a31d754c55a8c86527ca21e095338f352b /meta-oe/recipes-support/zstd/zstd_git.bb
parent6e3fc5b8d904d06e3aa77e9ec9968ab37a798188 (diff)
downloadmeta-openembedded-contrib-d6f699c1268947a2298f01af26f384c4465b633a.tar.gz
zstd: add new recipe
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support/zstd/zstd_git.bb')
-rw-r--r--meta-oe/recipes-support/zstd/zstd_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/zstd/zstd_git.bb b/meta-oe/recipes-support/zstd/zstd_git.bb
new file mode 100644
index 0000000000..2e92107ce1
--- /dev/null
+++ b/meta-oe/recipes-support/zstd/zstd_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Zstandard - Fast real-time compression algorithm"
+SECTION = "libs"
+HOMEPAGE = "http://www.zstd.net"
+LICENSE = "BSD-3-Clause | GPLv2"
+LIC_FILES_CHKSUM = "file://../../COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0 \
+ file://../../LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32"
+
+SRC_URI = "git://github.com/facebook/zstd;protocol=https"
+
+PV = "1.3.1+git${SRCPV}"
+SRCREV = "aecf3b479c45affa9fd8ead068e9160253a8ec5c"
+
+S = "${WORKDIR}/git/build/cmake"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DTHREADS_PTHREAD_ARG=2"
+
+PACKAGES =+ "${PN}-utils"
+FILES_${PN}-utils = "${bindir}"
+
+BBCLASSEXTEND = "native nativesdk"
+