aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl+baylibre@bgdev.pl>2017-09-14 10:13:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-18 10:18:11 +0200
commit6a12caa7fd6b1dfd09c2ea540ef7acc33b539a87 (patch)
tree71a0333b46bfd7b6cdd44b03e55b9c42cfc87b90 /meta-oe/recipes-support
parent6fa7a7d85efa490add3b13e2937dab625dac721a (diff)
downloadmeta-openembedded-contrib-6a12caa7fd6b1dfd09c2ea540ef7acc33b539a87.tar.gz
ceres-solver: add new recipe
Ceres Solver is an open source C++ library for modeling and solving large, complicated optimization problems. It's often used in 3D computer vision applications. Signed-off-by: Bartosz Golaszewski <brgl+baylibre@bgdev.pl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ceres-solver/ceres-solver_1.13.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ceres-solver/ceres-solver_1.13.bb b/meta-oe/recipes-support/ceres-solver/ceres-solver_1.13.bb
new file mode 100644
index 0000000000..e883c70d1d
--- /dev/null
+++ b/meta-oe/recipes-support/ceres-solver/ceres-solver_1.13.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Ceres Solver is an open source C++ library for modeling and solving large, complicated optimization problems."
+AUTHOR = "Sameer Agarwal and Keir Mierle and Others"
+HOMEPAGE = "http://ceres-solver.org/"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=35e00f0c4c96a0820a03e0b31e6416be"
+
+SRC_URI = "git://github.com/ceres-solver/ceres-solver.git"
+SRCREV = "19333b0f55c8462381038e70d42af43b52941128"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libeigen glog"
+
+inherit cmake
+
+# Only a static library and headers are created
+ALLOW_EMPTY_${PN} = "1"
+
+FILES_${PN}-dev += "${libdir}/cmake/*"