aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-21 10:58:08 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 13:06:13 +0200
commit36d57b9234c8d940205cf83e541302ef60b755c9 (patch)
tree111b53cf879e62ba22bbdb892b0589023c91f2d8 /meta-oe/recipes-support
parent0ee108356873f69229642d0c6f025f3328c5ff2f (diff)
downloadmeta-openembedded-contrib-36d57b9234c8d940205cf83e541302ef60b755c9.tar.gz
recipes: add missing pkgconfig class inherits
* These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util.inc2
-rw-r--r--meta-oe/recipes-support/evtest/evtest_1.25.bb2
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.0.13.bb2
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.0.bb2
-rw-r--r--meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb2
-rw-r--r--meta-oe/recipes-support/links/links.inc2
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb2
-rw-r--r--meta-oe/recipes-support/utouch/utouch-frame_git.bb2
-rw-r--r--meta-oe/recipes-support/utouch/utouch-mtview_git.bb2
9 files changed, 9 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util.inc b/meta-oe/recipes-support/dfu-util/dfu-util.inc
index 633b829b2a..892acad05c 100644
--- a/meta-oe/recipes-support/dfu-util/dfu-util.inc
+++ b/meta-oe/recipes-support/dfu-util/dfu-util.inc
@@ -6,4 +6,4 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
SRC_URI = "http://dfu-util.gnumonks.org/releases/dfu-util-${PV}.tar.gz"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta-oe/recipes-support/evtest/evtest_1.25.bb b/meta-oe/recipes-support/evtest/evtest_1.25.bb
index 34b5b74227..640cec0c75 100644
--- a/meta-oe/recipes-support/evtest/evtest_1.25.bb
+++ b/meta-oe/recipes-support/evtest/evtest_1.25.bb
@@ -11,4 +11,4 @@ SRC_URI = "http://cgit.freedesktop.org/~whot/evtest/snapshot/evtest-${PV}.tar.bz
SRC_URI[archive.md5sum] = "770d6af03affe976bdbe3ad1a922c973"
SRC_URI[archive.sha256sum] = "3d34123c68014dae6f7c19144ef79ea2915fa7a2f89ea35ca375a9cf9e191473"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
index 3205aaf357..48a80e5985 100644
--- a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
+++ b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
@@ -16,7 +16,7 @@ DEPENDS = "glib-2.0 gstreamer"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
-inherit autotools
+inherit autotools pkgconfig
FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la"
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb
index d92e6395f8..ec2a09de40 100644
--- a/meta-oe/recipes-support/gd/gd_2.1.0.bb
+++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531d
S = "${WORKDIR}/libgd-${PV}"
-inherit autotools binconfig gettext
+inherit autotools binconfig gettext pkgconfig
EXTRA_OECONF += " --disable-rpath \
--with-jpeg=${STAGING_LIBDIR}/.. \
diff --git a/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb b/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
index 21f4e2ac4b..16657b4b13 100644
--- a/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
+++ b/meta-oe/recipes-support/libatasmart/libatasmart_0.19.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://git.0pointer.de/libatasmart.git"
S = "${WORKDIR}/git"
-inherit autotools lib_package
+inherit autotools lib_package pkgconfig
do_install_append() {
sed -i -e s://:/:g -e 's:=${libdir}/libudev.la:-ludev:g' ${D}${libdir}/libatasmart.la
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc
index 78d7ec78df..ef48d737e6 100644
--- a/meta-oe/recipes-support/links/links.inc
+++ b/meta-oe/recipes-support/links/links.inc
@@ -14,4 +14,4 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,lzma"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
index bb649a2337..82e5d8a15c 100644
--- a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2"
SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a"
SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
-inherit autotools gettext
+inherit autotools gettext pkgconfig
S = "${WORKDIR}/dpkg-${PV}"
diff --git a/meta-oe/recipes-support/utouch/utouch-frame_git.bb b/meta-oe/recipes-support/utouch/utouch-frame_git.bb
index 00b7cf355e..d9b38ae204 100644
--- a/meta-oe/recipes-support/utouch/utouch-frame_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-frame_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
DEPENDS += "mtdev utouch-evemu"
-inherit autotools
+inherit autotools pkgconfig
SRC_URI = "git://bitmath.org/git/frame.git;protocol=http"
SRCREV = "95363d5a1f7394d71144bf3b408ef4e6db4350fc"
diff --git a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
index 6ebeb9fa4b..bcf7e23846 100644
--- a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://bitmath.org/code/mtview/"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=4c61b8950dc1aab4d2aa7c2ae6b1cfb3"
-inherit autotools
+inherit autotools pkgconfig
SRC_URI = "git://bitmath.org/git/mtview.git;protocol=http"
SRCREV = "ad437c38dc111cf3990a03abf14efe1b5d89604b"