aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-09-19 11:24:18 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-19 08:24:55 +0200
commit6cbe04603a429303dfda628552fcead5c43e317e (patch)
tree6f853f94992ce0b759bb725ee5f7e2142b092064 /meta-oe/recipes-support
parente50b52752d208ae3805bde10dc97e4892a563fd4 (diff)
downloadmeta-openembedded-contrib-6cbe04603a429303dfda628552fcead5c43e317e.tar.gz
imagemagick: Fix configure on x86_64
imagemagick has configure time execution test for large file offset they wont be able to run in cross compile. We cache it. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.4.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.4.4.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.4.4.bb
index 40f9736cc7..c38c644cd5 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_6.4.4.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.4.4.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e1ebcc1358b9f81eba64255fc5da6892"
# FIXME: There is much more checked libraries. All should be added or explicitly disabled to get consistent results.
DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib"
-PR = "r7"
+PR = "r8"
PATCHSET = "1"
SRC_URI = "ftp://ftp.nluug.nl/pub/ImageMagick/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
@@ -32,3 +32,7 @@ FILES_${PN}-dbg += "${libdir}/ImageMagick-${IMVER}/modules-Q16/*/.debug/*"
BBCLASSEXTEND = "native"
LEAD_SONAME = "libMagickCore.so.*"
+
+do_configure_prepend() {
+ export ac_cv_sys_file_offset_bits=yes
+}