aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 14:15:14 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:37 -0800
commita1c660848d8f3879ad4396b021e3dafdefeda333 (patch)
tree09c4936ef0ace6062fb433e119ad9c9d25fc5e48 /meta-oe/recipes-support
parent0df104e33d7f9aa969af56ff12756f09269e8e7a (diff)
downloadmeta-openembedded-contrib-a1c660848d8f3879ad4396b021e3dafdefeda333.tar.gz
passwdqc: move to recipes-security
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch31
-rw-r--r--meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb63
2 files changed, 0 insertions, 94 deletions
diff --git a/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch b/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch
deleted file mode 100644
index e9023492e0..0000000000
--- a/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable.
-
-Upstream-Status: Pending
-
-Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
-
-diff --git a/Makefile b/Makefile
-index 49d622d..cd17334 100644
---- a/Makefile
-+++ b/Makefile
-@@ -48,18 +48,17 @@ CFLAGS = -Wall -W -O2
- CFLAGS_lib = $(CFLAGS) -fPIC
- CFLAGS_bin = $(CFLAGS) -fomit-frame-pointer
-
--LDFLAGS =
- LDFLAGS_shared = --shared
- LDFLAGS_shared_LINUX = --shared
- LDFLAGS_shared_SUN = -G
- LDFLAGS_shared_HP = -b
- LDFLAGS_lib = $(LDFLAGS_shared)
--LDFLAGS_lib_LINUX = $(LDFLAGS_shared_LINUX) \
-+LDFLAGS_lib_LINUX = $(LDFLAGS) $(LDFLAGS_shared_LINUX) \
- -Wl,--soname,$(SHARED_LIB),--version-script,$(MAP_LIB)
- LDFLAGS_lib_SUN = $(LDFLAGS_shared_SUN)
- LDFLAGS_lib_HP = $(LDFLAGS_shared_HP)
- LDFLAGS_pam = $(LDFLAGS_shared)
--LDFLAGS_pam_LINUX = $(LDFLAGS_shared_LINUX) \
-+LDFLAGS_pam_LINUX = $(LDFLAGS) $(LDFLAGS_shared_LINUX) \
- -Wl,--version-script,$(MAP_PAM)
- LDFLAGS_pam_SUN = $(LDFLAGS_shared_SUN)
- LDFLAGS_pam_HP = $(LDFLAGS_shared_HP)
diff --git a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb b/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
deleted file mode 100644
index 198db3ce72..0000000000
--- a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
+++ /dev/null
@@ -1,63 +0,0 @@
-SUMMARY = "A password/passphrase strength checking and enforcement toolset"
-DESCRIPTION = "\
-passwdqc is a password/passphrase strength checking and policy enforcement \
-toolset, including an optional PAM module (pam_passwdqc), command-line \
-programs (pwqcheck and pwqgen), and a library (libpasswdqc). \
-pam_passwdqc is normally invoked on password changes by programs such as \
-passwd(1). It is capable of checking password or passphrase strength, \
-enforcing a policy, and offering randomly-generated passphrases, with \
-all of these features being optional and easily (re-)configurable. \
-\
-pwqcheck and pwqgen are standalone password/passphrase strength checking \
-and random passphrase generator programs, respectively, which are usable \
-from scripts. \
-\
-libpasswdqc is the underlying library, which may also be used from \
-third-party programs. \
-"
-
-HOMEPAGE = "http://www.openwall.com/passwdqc"
-SECTION = "System Environment/Base"
-
-DEPENDS += "libpam"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d"
-
-SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \
- file://makefile-add-ldflags.patch \
- "
-SRC_URI[md5sum] = "3878b57bcd3fdbcf3d4b362dbc6228b9"
-SRC_URI[sha256sum] = "d1fedeaf759e8a0f32d28b5811ef11b5a5365154849190f4b7fab670a70ffb14"
-
-# explicitly define LINUX_PAM in case DISTRO_FEATURES no pam
-# this package's pam_passwdqc.so needs pam
-CFLAGS_append += "-Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM"
-
-# -e is no longer default setting in bitbake.conf
-EXTRA_OEMAKE = "-e"
-
-do_compile() {
- # make sure sub make use environment to override variables in Makefile
- # Linux) $(MAKE), there is a tab between
- sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile
-
- # LD_lib and LD must be CC because of Makefile
- oe_runmake LD="${CC}"
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \
- DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \
- INSTALL="install -p"
-}
-
-PROVIDES += "pam-${BPN}"
-PACKAGES =+ "lib${BPN} pam-${BPN}"
-
-FILES_lib${BPN} = "${base_libdir}/libpasswdqc.so.0"
-FILES_pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so"
-FILES_${PN}-dbg += "${base_libdir}/security/.debug"
-
-RDEPENDS_${PN} = "lib${BPN} pam-${BPN}"
-RDEPENDS_pam-${BPN} = "lib${BPN}"