aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-12-15 06:11:31 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:24 +0100
commit1e2491d12520d767e0e5687a9b15819fe0b6ff27 (patch)
treee0c90ec74255845041012d4087b0a11af0c8d816 /meta-oe/recipes-test/gtest/gtest_1.8.0.bb
parentc4e9e1c9acecc9b46a9ec6fe2c123c223e9961e8 (diff)
downloadmeta-openembedded-contrib-1e2491d12520d767e0e5687a9b15819fe0b6ff27.tar.gz
gtest, gmock: update 1.7.0 -> 1.8.0
Starting from the 1.8.0 release, GoogleTest and GoogleMock are maintained in the same repository and released together. Update the gtest recipe to PROVIDE gmock (and drop the gmock recipe). Patches to add CMake install rules have been dropped (now supported upstream). https://github.com/google/googletest/commit/98d988deac06637364f6cd41c45c3db4a8a0b6bc https://github.com/google/googletest/commit/7c8ac4886a7ad513430d132c446a93c6d395345a Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/gtest/gtest_1.8.0.bb')
-rw-r--r--meta-oe/recipes-test/gtest/gtest_1.8.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest_1.8.0.bb b/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
new file mode 100644
index 0000000000..483dc1f2e9
--- /dev/null
+++ b/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Google's framework for writing C++ tests"
+HOMEPAGE = "https://github.com/google/googletest"
+SECTION = "libs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
+ file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
+
+PROVIDES += "gmock"
+
+SRC_URI = "\
+ https://github.com/google/googletest/archive/release-${PV}.tar.gz \
+ file://Add-pkg-config-support.patch \
+"
+
+SRC_URI[md5sum] = "16877098823401d1bf2ed7891d7dce36"
+SRC_URI[sha256sum] = "58a6f4277ca2bc8565222b3bbd58a177609e9c488e8a72649359ba51450db7d8"
+
+S = "${WORKDIR}/googletest-release-${PV}"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dbg = "1"
+
+RDEPENDS_${PN}-dev += "${PN}-staticdev"
+
+BBCLASSEXTEND = "native nativesdk"