aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorchangqing.li@windriver.com <changqing.li@windriver.com>2018-06-29 14:22:17 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-29 07:00:52 -0700
commit318c9572d26b8ff16b3b6ba43c22c11894f6dde2 (patch)
tree1a17498c9fd91b9aaddc40ce62e79b0df91c1679 /meta-oe
parent6e47ace16f6914d8a0006c790a2dfdff02468ade (diff)
downloadmeta-openembedded-contrib-318c9572d26b8ff16b3b6ba43c22c11894f6dde2.tar.gz
vim/vim-tiny: upgrade 8.0.0983 -> 8.1.0.116
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/vim/files/CVE-2017-17087.patch70
-rw-r--r--meta-oe/recipes-support/vim/files/disable_acl_header_check.patch28
-rw-r--r--meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch16
-rw-r--r--meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb (renamed from meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb)0
-rw-r--r--meta-oe/recipes-support/vim/vim_8.1.0.116.bb (renamed from meta-oe/recipes-support/vim/vim_8.0.0983.bb)7
5 files changed, 33 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
deleted file mode 100644
index 937b9ba317..0000000000
--- a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 9c11f80339372b7aa2f43153d574f2b5abb79708 Mon Sep 17 00:00:00 2001
-From: Li Zhou <li.zhou@windriver.com>
-Date: Sun, 17 Dec 2017 23:09:35 -0800
-Subject: [PATCH] vim: patch 8.0.1263: others can read the swap file if a user
- is careless
-
-Problem: Others can read the swap file if a user is careless with his
- primary group.
-Solution: If the group permission allows for reading but the world
- permissions doesn't, make sure the group is right.
-
-Upstream-Status: Backport
-CVE: CVE-2017-17087
-Signed-off-by: Li Zhou <li.zhou@windriver.com>
----
- src/fileio.c | 24 +++++++++++++++++++++++-
- src/version.c | 2 ++
- 2 files changed, 25 insertions(+), 1 deletion(-)
-
-diff --git a/src/fileio.c b/src/fileio.c
-index f54fb8465..2c7740af9 100644
---- a/src/fileio.c
-+++ b/src/fileio.c
-@@ -716,7 +716,29 @@ readfile(
- /* Set swap file protection bits after creating it. */
- if (swap_mode > 0 && curbuf->b_ml.ml_mfp != NULL
- && curbuf->b_ml.ml_mfp->mf_fname != NULL)
-- (void)mch_setperm(curbuf->b_ml.ml_mfp->mf_fname, (long)swap_mode);
-+ {
-+ char_u *swap_fname = curbuf->b_ml.ml_mfp->mf_fname;
-+
-+ /*
-+ * If the group-read bit is set but not the world-read bit, then
-+ * the group must be equal to the group of the original file. If
-+ * we can't make that happen then reset the group-read bit. This
-+ * avoids making the swap file readable to more users when the
-+ * primary group of the user is too permissive.
-+ */
-+ if ((swap_mode & 044) == 040)
-+ {
-+ stat_T swap_st;
-+
-+ if (mch_stat((char *)swap_fname, &swap_st) >= 0
-+ && st.st_gid != swap_st.st_gid
-+ && fchown(curbuf->b_ml.ml_mfp->mf_fd, -1, st.st_gid)
-+ == -1)
-+ swap_mode &= 0600;
-+ }
-+
-+ (void)mch_setperm(swap_fname, (long)swap_mode);
-+ }
- #endif
- }
-
-diff --git a/src/version.c b/src/version.c
-index a5cb078f0..5c0df475f 100644
---- a/src/version.c
-+++ b/src/version.c
-@@ -770,6 +770,8 @@ static char *(features[]) =
- static int included_patches[] =
- { /* Add new patch number below this line */
- /**/
-+ 1263,
-+/**/
- 983,
- /**/
- 982,
---
-2.11.0
-
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
index 65e5f58c61..4720003c25 100644
--- a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
+++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
@@ -1,14 +1,23 @@
-Upstream-Status: pending
+From 5ed25c076a1fb1889a3c50dddf29f21850b59a13 Mon Sep 17 00:00:00 2001
+From: Wenzong Fan <wenzong.fan@windriver.com>
+Date: Tue, 26 Jun 2018 17:29:09 +0800
+Subject: [PATCH] disable acl header check
Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny.
+Upstream-Status: pending
+
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
-================================================
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ src/configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
diff --git a/src/configure.ac b/src/configure.ac
-index fb965e5..d734064 100644
+index 107c170..0ee86ad 100644
--- a/src/configure.ac
+++ b/src/configure.ac
-@@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \
+@@ -3220,7 +3220,7 @@ AC_CHECK_HEADERS(stdint.h stdlib.h string.h \
sys/systeminfo.h locale.h sys/stream.h termios.h \
libc.h sys/statfs.h poll.h sys/poll.h pwd.h \
utime.h sys/param.h libintl.h libgen.h \
@@ -17,11 +26,14 @@ index fb965e5..d734064 100644
sys/access.h sys/sysinfo.h wchar.h wctype.h)
dnl sys/ptem.h depends on sys/stream.h on Solaris
-@@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl,
+@@ -3848,6 +3848,7 @@ AC_ARG_ENABLE(acl,
, [enable_acl="yes"])
if test "$enable_acl" = "yes"; then
- AC_MSG_RESULT(no)
-+AC_CHECK_HEADERS(sys/acl.h)
- AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
+ AC_MSG_RESULT(no)
++ AC_CHECK_HEADERS(sys/acl.h)
+ AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl"
AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),)
+--
+2.7.4
+
diff --git a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
index 6c620f9f27..37914d4cd9 100644
--- a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
+++ b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
@@ -1,20 +1,24 @@
-vim: add knob whether elf.h are checked
+From 38de4bccdb8a861ffdd447f12fdab19d6d852c02 Mon Sep 17 00:00:00 2001
+From: Chong Lu <Chong.Lu@windriver.com>
+Date: Tue, 26 Jun 2018 17:34:15 +0800
+Subject: [PATCH] vim: add knob whether elf.h are checked
Previously, it still was checked when there was no elf library in sysroots directory.
Add knob to decide whether elf.h are checked or not.
-Upstream-status: Pending
+Upstream-Status: Pending
Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
- src/configure.ac | 7 +++++++
+ src/configure.ac | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/src/configure.ac b/src/configure.ac
-index d734064..f504fa6 100644
+index 0ee86ad..64736f0 100644
--- a/src/configure.ac
+++ b/src/configure.ac
-@@ -2483,11 +2483,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));],
+@@ -3192,11 +3192,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));],
AC_MSG_RESULT(no))
dnl Checks for header files.
@@ -34,5 +38,5 @@ index d734064..f504fa6 100644
AC_HEADER_DIRENT
--
-1.7.9.5
+2.7.4
diff --git a/meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb b/meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb
index bb8f2b7eae..bb8f2b7eae 100644
--- a/meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb
+++ b/meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0983.bb b/meta-oe/recipes-support/vim/vim_8.1.0.116.bb
index 44c868c74a..f669dfea4d 100644
--- a/meta-oe/recipes-support/vim/vim_8.0.0983.bb
+++ b/meta-oe/recipes-support/vim/vim_8.1.0.116.bb
@@ -4,14 +4,13 @@ DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=eea32ac1424bba14096736a494ae9045"
+LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b6eb9d541de3933cc8f48125ae0335fe"
SRC_URI = "git://github.com/vim/vim.git \
file://disable_acl_header_check.patch;patchdir=.. \
file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
- file://CVE-2017-17087.patch;patchdir=.. \
"
-SRCREV = "3f9a1ff141412e9e85f7dff47d02946cb9be9228"
+SRCREV = "a87b72cc316e065d66dcbcf7ec1cde330adef3a3"
S = "${WORKDIR}/git/src"
@@ -54,7 +53,7 @@ EXTRA_OECONF = " \
vim_cv_memmove_handles_overlap=yes \
vim_cv_stat_ignores_slash=no \
vim_cv_terminfo=yes \
- vim_cv_tgent=non-zero \
+ vim_cv_tgetent=non-zero \
vim_cv_toupper_broken=no \
vim_cv_tty_group=world \
STRIP=/bin/true \