aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-03 19:52:11 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-03 19:55:28 -0800
commit18e92f2c6c2a5ea714a7b1ea8196b272995217b4 (patch)
treeed19f3eef564a08d7b387318c3c2c9827c559989 /meta-oe
parentb22572517b2984653439eaa045ae519ebc91d84a (diff)
downloadmeta-openembedded-contrib-18e92f2c6c2a5ea714a7b1ea8196b272995217b4.tar.gz
libyui-ncurses: Pass -DNCURSES_WIDECHAR in CXXFLAGS
We want the wide character functions from the ncurses header. Unfortunately it doesn't provide them by default, but only if either: * NCURSES_WIDECHAR is defined (for ncurses 20111030 and up) * _XOPEN_SOURCE/_XOPEN_SOURCE_EXTENDED are suitably defined So far we have been implicitly relying on the latter, because for GNU libc when we define _GNU_SOURCE this causes libc to define the _XOPEN_SOURCE macros for us. Unfortunately this doesn't work on all libcs, because some (like musl libc) do not define _XOPEN_SOURCE when _GNU_SOURCE is defined. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses_4.0.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_4.0.0.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_4.0.0.bb
index 333163deba..a3a4a15066 100644
--- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_4.0.0.bb
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_4.0.0.bb
@@ -21,6 +21,8 @@ BBCLASSEXTEND = "nativesdk"
EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RELWITHDEBINFO -DWERROR=OFF"
+CXXFLAGS += "-DNCURSES_WIDECHAR"
+
do_configure_prepend () {
cd ${S}
if [ -e ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so ]; then