aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2021-02-23 22:16:37 +0000
committerKhem Raj <raj.khem@gmail.com>2021-03-03 19:55:28 -0800
commitdad2aef6be76564103952e0ad78a7d666b49f72e (patch)
treeef83abe77cb7897f551d360275fe1c81372a74c4 /meta-oe
parent5593fac20fed30069baf369aba71dbfd355e08a7 (diff)
downloadmeta-openembedded-contrib-dad2aef6be76564103952e0ad78a7d666b49f72e.tar.gz
nss: Fix warnings generated by getcwd
getcwd() conforms to POSIX.1-2001 which leaves the behaviour when the buf argument is NULL, undefined. This makes gcc 10+ throw the following warning: argument 1 is null but the corresponding size argument 2 value is 4096 Initially, this was fixed by disabling NSS_ENABLE_WERROR. This patch re-enables NSS_ENABLE_WERROR (by leaving it to its default value) and takes advantage of the existing functionality in nss that wraps the getcwd call into a function making sure that the buf argument is always properly allocated. Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/nss/nss_3.60.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.60.1.bb b/meta-oe/recipes-support/nss/nss_3.60.1.bb
index 25a2bc2513..0d668ba067 100644
--- a/meta-oe/recipes-support/nss/nss_3.60.1.bb
+++ b/meta-oe/recipes-support/nss/nss_3.60.1.bb
@@ -76,7 +76,6 @@ do_compile_prepend_class-native() {
do_compile() {
export NSPR_INCLUDE_DIR=${STAGING_INCDIR}/nspr
- export NSS_ENABLE_WERROR=0
export CROSS_COMPILE=1
export NATIVE_CC="${BUILD_CC}"
@@ -84,6 +83,10 @@ do_compile() {
export NATIVE_FLAGS="${BUILD_CFLAGS} -DLINUX -Dlinux"
export BUILD_OPT=1
+ # POSIX.1-2001 states that the behaviour of getcwd() when passing a null
+ # pointer as the buf argument, is unspecified.
+ export NATIVE_FLAGS="${NATIVE_FLAGS} -DGETCWD_CANT_MALLOC"
+
export FREEBL_NO_DEPEND=1
export FREEBL_LOWHASH=1