aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorYi-Soo An <yisooan@gmail.com>2018-11-01 22:08:38 +0900
committerKhem Raj <raj.khem@gmail.com>2018-11-01 10:04:54 -0700
commit3cb22639385e9a359f1726b46a8467e1ef4c0fe0 (patch)
treef8d2f483d75915703ab29805cf28b1d5388510c1 /meta-oe
parentf1511d254632a34c1deb51f4bf8b8c21e7423f51 (diff)
downloadmeta-openembedded-contrib-3cb22639385e9a359f1726b46a8467e1ef4c0fe0.tar.gz
uftrace: Support x86
If TARGET_ARCH is not set to i386 for x86, build will be failed with logs such as "arch/i586: No such file or directory". In this case, TARGET_ARCH is set to i586. To succeed the build, add additional function named set_target_arch. Signed-off-by: Yi-Soo An <yisooan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
index e377a5c9d5..ca38e6aa21 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
@@ -18,7 +18,16 @@ SRC_URI = "git://github.com/namhyung/${BPN} \
S = "${WORKDIR}/git"
LDFLAGS_append_libc-musl = " -largp"
-EXTRA_UFTRACE_OECONF = "ARCH=${TARGET_ARCH} \
+
+def set_target_arch(d):
+ import re
+ arch = d.getVar('TARGET_ARCH', True)
+ if re.match(r'i.86', arch, re.I):
+ return 'i386'
+ else:
+ return arch
+
+EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
with_elfutils=/use/libelf/from/sysroot"
do_configure() {
@@ -28,7 +37,7 @@ do_configure() {
FILES_SOLIBSDEV = ""
FILES_${PN} += "${libdir}/*.so"
-COMPATIBLE_HOST = "(x86_64|aarch64|arm)"
+COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
# uftrace supports armv6 and above
COMPATIBLE_HOST_armv4 = 'null'