aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-04-18 20:12:13 +0200
committerMichael Lippautz <michael.lippautz@gmail.com>2011-04-18 20:59:07 +0200
commit02e3e6814c3c74050c9cdca48523a2496772bc4a (patch)
tree2b3c261f04d03c1260c483b3ceb082f813f374c1 /meta-oe
parentfc04fe74edfe5a681ed1ee5e0458e085573f9177 (diff)
downloadmeta-openembedded-contrib-02e3e6814c3c74050c9cdca48523a2496772bc4a.tar.gz
wget: Add version 1.11.4
* Changes from org.oe.dev: ssl autodetection uses staging dirs Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/wget/wget.inc30
-rw-r--r--meta-oe/recipes-connectivity/wget/wget_1.11.4.bb7
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wget/wget.inc b/meta-oe/recipes-connectivity/wget/wget.inc
new file mode 100644
index 0000000000..8903fee36b
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wget/wget.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
+SECTION = "console/network"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+INC_PR = "r10"
+
+S = "${WORKDIR}/wget-${PV}"
+
+inherit autotools gettext
+
+EXTRA_OECONF = " \
+ --enable-ipv6
+ --with-libssl-prefix=${STAGING_DIR}${HOST_SYS}"
+
+# The unslung kernel does not support ipv6
+EXTRA_OECONF_unslung = "--without-ssl"
+# SlugOS kernels do not support ipv6. Can be loaded as a module.
+EXTRA_OECONF_slugos = "--without-ssl"
+
+do_install_append () {
+ mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/wget wget wget.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove wget wget.${PN}
+}
diff --git a/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb b/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb
new file mode 100644
index 0000000000..b9f27f87d8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb
@@ -0,0 +1,7 @@
+PR="${INC_PR}.0"
+
+SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz"
+SRC_URI[md5sum] = "69e8a7296c0e12c53bd9ffd786462e87"
+SRC_URI[sha256sum] = "7315963b6eefb7530b4a4f63a5d5ccdab30078784cf41ccb5297873f9adea2f3"
+
+require wget.inc