aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-08 10:33:44 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-08 10:33:44 +0200
commit3ea3ee67551b3405dc0355f9f4fa2c2df37bbace (patch)
tree0abd482a607fb5ea3f3d42488de8b5fd0d3e4582 /meta-oe
parent6889c5370ebabed45567ba4379f2a0fd29d871f1 (diff)
parent7e5b1e477a25c3dc661a2c155a22022a07903d0a (diff)
downloadmeta-openembedded-contrib-3ea3ee67551b3405dc0355f9f4fa2c2df37bbace.tar.gz
Merge remote-tracking branch 'meta-oe-contrib/jansa/pull2'
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/classes/kernel.bbclass9
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch10
-rw-r--r--meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb5
-rw-r--r--meta-oe/recipes-core/glib-2.0/glibmm/glib-2.32.patch10
-rw-r--r--meta-oe/recipes-core/glib-2.0/glibmm_2.28.2.bb7
-rw-r--r--meta-oe/recipes-devtools/libgee/libgee_0.6.0.bb12
-rw-r--r--meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb11
-rw-r--r--meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb (renamed from meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.9.bb)7
8 files changed, 45 insertions, 26 deletions
diff --git a/meta-oe/classes/kernel.bbclass b/meta-oe/classes/kernel.bbclass
index 98320feeda..b431f8e1d5 100644
--- a/meta-oe/classes/kernel.bbclass
+++ b/meta-oe/classes/kernel.bbclass
@@ -1,7 +1,7 @@
inherit linux-kernel-base module_strip
PROVIDES += "virtual/kernel"
-DEPENDS += "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX} update-modules"
+DEPENDS += "virtual/${TARGET_PREFIX}gcc kmod-native virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX} update-modules"
# we include gcc above, we dont need virtual/libc
INHIBIT_DEFAULT_DEPS = "1"
@@ -252,7 +252,7 @@ EXPORT_FUNCTIONS do_compile do_install do_configure
# kernel-base becomes kernel-${KERNEL_VERSION}
# kernel-image becomes kernel-image-${KERNEL_VERISON}
-PACKAGES = "kernel kernel-base kernel-image kernel-dev kernel-vmlinux kernel-misc"
+PACKAGES = "kernel kernel-base kernel-vmlinux kernel-image kernel-dev kernel-misc"
FILES = ""
FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
FILES_kernel-dev = "/boot/System.map* /boot/Module.symvers* /boot/config*"
@@ -274,7 +274,7 @@ if [ ! -e "$D/lib/modules/${KERNEL_VERSION}" ]; then
mkdir -p $D/lib/modules/${KERNEL_VERSION}
fi
if [ -n "$D" ]; then
- ${HOST_PREFIX}depmod -A -b $D -F ${STAGING_KERNEL_DIR}/System.map-${KERNEL_VERSION} ${KERNEL_VERSION}
+ depmod -a -b $D -F ${STAGING_KERNEL_DIR}/System.map-${KERNEL_VERSION} ${KERNEL_VERSION}
else
depmod -a
fi
@@ -352,9 +352,8 @@ python populate_packages_prepend () {
if m:
kernelver_stripped = m.group(1)
path = d.getVar("PATH", True)
- host_prefix = d.getVar("HOST_PREFIX", True) or ""
- cmd = "PATH=\"%s\" %sdepmod -n -a -r -b %s -F %s/boot/System.map-%s %s" % (path, host_prefix, dvar, dvar, kernelver, kernelver_stripped)
+ cmd = "PATH=\"%s\" depmod -n -a -b %s -F %s/boot/System.map-%s %s" % (path, dvar, dvar, kernelver, kernelver_stripped)
f = os.popen(cmd, 'r')
deps = {}
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch
new file mode 100644
index 0000000000..b6c9422e8c
--- /dev/null
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth-1.4.3/glib-2.32.patch
@@ -0,0 +1,10 @@
+--- loudmouth-1.4.3.orig/loudmouth/lm-error.c 2008-10-29 21:48:15.000000000 +0100
++++ loudmouth-1.4.3/loudmouth/lm-error.c 2012-05-06 08:27:07.455739440 +0200
+@@ -19,7 +19,6 @@
+ */
+
+ #include <config.h>
+-#include <glib/gerror.h>
+ #include "lm-error.h"
+
+ /**
diff --git a/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb b/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb
index f91fdff07e..87852ee746 100644
--- a/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb
+++ b/meta-oe/recipes-connectivity/loudmouth/loudmouth_1.4.3.bb
@@ -8,7 +8,10 @@ DEPENDS = "glib-2.0 check openssl"
inherit gnomebase
-SRC_URI += "file://04-use-pkg-config-for-gnutls.patch"
+PR = "r1"
+
+SRC_URI += "file://04-use-pkg-config-for-gnutls.patch \
+ file://glib-2.32.patch"
SRC_URI[archive.md5sum] = "55339ca42494690c3942ee1465a96937"
SRC_URI[archive.sha256sum] = "95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3"
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm/glib-2.32.patch b/meta-oe/recipes-core/glib-2.0/glibmm/glib-2.32.patch
new file mode 100644
index 0000000000..50b7367c5a
--- /dev/null
+++ b/meta-oe/recipes-core/glib-2.0/glibmm/glib-2.32.patch
@@ -0,0 +1,10 @@
+--- glibmm-2.28.2.orig/glib/glibmm/varianttype.cc 2011-06-09 20:29:48.000000000 +0200
++++ glibmm-2.28.2/glib/glibmm/varianttype.cc 2012-05-06 08:15:32.760680295 +0200
+@@ -23,7 +23,6 @@
+
+ #include <glibmm/varianttype.h>
+ #include <glibmm/utility.h>
+-#include <glib/gvarianttype.h>
+
+ namespace Glib
+ {
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm_2.28.2.bb b/meta-oe/recipes-core/glib-2.0/glibmm_2.28.2.bb
index 7e77a1c9cf..6604091fe3 100644
--- a/meta-oe/recipes-core/glib-2.0/glibmm_2.28.2.bb
+++ b/meta-oe/recipes-core/glib-2.0/glibmm_2.28.2.bb
@@ -1,10 +1,9 @@
require glibmm.inc
-PR = "r1"
+PR = "r2"
SRC_URI[archive.md5sum] = "cf33d1861d09fb2952a6a1d69e0502e3"
SRC_URI[archive.sha256sum] = "7b67178363f8494c94f8b3dd704a4c8db7ad75a253fc84a4ad229e5e179ec192"
-SRC_URI += " file://remove-examples.patch"
-
-
+SRC_URI += " file://remove-examples.patch \
+ file://glib-2.32.patch"
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.6.0.bb b/meta-oe/recipes-devtools/libgee/libgee_0.6.0.bb
deleted file mode 100644
index 4e305b6049..0000000000
--- a/meta-oe/recipes-devtools/libgee/libgee_0.6.0.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-require libgee.inc
-PE = "1"
-PR = "${INC_PR}.1"
-#autoreconf needs introspection.m4 (staged by gobject-introspection-native) after http://git.gnome.org/browse/libgee/commit/?id=d026a29b38ca1a3388981c6e75a92602212373d8
-DEPENDS += "gobject-introspection-native"
-DEPENDS_virtclass-native += "gobject-introspection-native"
-
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/0.6/${BPN}-${PV}.tar.bz2"
-S = "${WORKDIR}/${BPN}-${PV}"
-
-SRC_URI[md5sum] = "4eb513b23ab6ea78884989518a4acf6f"
-SRC_URI[sha256sum] = "e586678d0a88637abeaaf850b62231000772e79ea6d9c4b45dc3cea99f778a7a"
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb
new file mode 100644
index 0000000000..4e2c6438e9
--- /dev/null
+++ b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb
@@ -0,0 +1,11 @@
+require libgee.inc
+PE = "1"
+PR = "${INC_PR}.0"
+#autoreconf needs introspection.m4 (staged by gobject-introspection-native) after http://git.gnome.org/browse/libgee/commit/?id=d026a29b38ca1a3388981c6e75a92602212373d8
+DEPENDS += "gobject-introspection-native"
+DEPENDS_virtclass-native += "gobject-introspection-native"
+
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz"
+SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22"
+SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665"
diff --git a/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.9.bb b/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb
index ea4f38b675..89338d9c30 100644
--- a/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.9.bb
+++ b/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb
@@ -2,13 +2,12 @@ require recipes-graphics/xorg-lib/xorg-lib-common.inc
DESCRIPTION = "X Athena Widget Set"
DEPENDS += "xproto virtual/libx11 libxext xextproto libxt libxmu libxpm libxp printproto libxau xmlto-native"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f1beacbc336a5a256bb28dbfcf01c2be"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1c65719d42900bb81b83e8293c20a364"
PE = "1"
-PR = "r12"
-SRC_URI[md5sum] = "ccc57478c41b7a75b9702241b889b1d4"
-SRC_URI[sha256sum] = "a83977546b78e24ac5dca86affc10b6404a87c16272405b05386feca1a2db037"
+SRC_URI[md5sum] = "f1ea52debce7a18cc26b21647a00ad8b"
+SRC_URI[sha256sum] = "2d96bcf92638b8ec5c91d379f5ec2e7b15133adeb2ba22066d48bf3239ee1bdd"
# disable docs as groff detection doesn't work on some hosts while cross compilling
EXTRA_OECONF += " --disable-docs "