aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorConnor Smith <connor.smith@ni.com>2015-05-26 16:00:49 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 10:35:17 +0200
commitd39e069ddb99f85d3a5c9897d9abfc41b7a63d50 (patch)
tree42b3b04166040b67b2d6de97f373b246356d8736 /meta-oe
parenta9eb0fc60dd2d1ecac9cbb321fcbe51b9cf69801 (diff)
downloadmeta-openembedded-contrib-d39e069ddb99f85d3a5c9897d9abfc41b7a63d50.tar.gz
tree: add new recipe
Tree is a recursive directory listing command that is useful for viewing directory contents in a tree-like format. Signed-off-by: Connor Smith <connor.smith@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/tree/tree_1.7.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tree/tree_1.7.0.bb b/meta-oe/recipes-support/tree/tree_1.7.0.bb
new file mode 100644
index 0000000000..507b12a397
--- /dev/null
+++ b/meta-oe/recipes-support/tree/tree_1.7.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "a recursive directory listing command"
+HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "ftp://mama.indstate.edu/linux/${BPN}/${BP}.tgz"
+SRC_URI[md5sum] = "abe3e03e469c542d8e157cdd93f4d8a6"
+SRC_URI[sha256sum] = "6957c20e82561ac4231638996e74f4cfa4e6faabc5a2f511f0b4e3940e8f7b12"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/${BPN}
+}