aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-03-01 23:23:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-03 08:36:00 +0100
commitfe1f11a062da26736dc4fe7f6625f1595689d66e (patch)
treee252707d0d429e7eedfd125ff3d586550cb0247f /meta-oe
parentd523cc183903fd0bc2e53af6af99a88ea1652e0d (diff)
downloadmeta-openembedded-contrib-fe1f11a062da26736dc4fe7f6625f1595689d66e.tar.gz
qt-creator: avoid conflicts with meta-qt5's qt5-creator
We avoid conflicts by installing no files to sysroot. This causes no fallout because nothing depends on qt5-creator (if something included later depending on qt-creator it should depend on qt5-creator). Note that | WARNING: QA Issue: qt5-creator rdepends on qt-creator, but it isn't a build dependency? [build-deps] is a false positve because the names of the libraries are same as for qt5-creator (see test below). This patch was tested by: 1. building qt-creator from scratch 2. building an image containing qt5-creator. * qt5-creator did not fail for sysroot conflicts * image was build without pulling qt-creator Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb b/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb
index 11d7be7d62..670ffad010 100644
--- a/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb
+++ b/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb
@@ -33,6 +33,11 @@ RRECOMMENDS_${PN} += "packagegroup-core-buildessential \
qt4-plugin-sqldriver-sqlite \
"
+# avoid conflicts with meta-qt5's qt-creator and do install nothing to sysroot
+# this does no harm cause nothing depends on qt-creator
+sysroot_stage_all() {
+}
+
# the regexp in insane.bbclass doesn't allow this valid path:
# qt-creator-2.8.1: qt-creator: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/libqbs_cpp_scanner.so
# qt-creator: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/libqbs_qt_scanner.so