aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-07-25 18:08:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 09:35:44 +0200
commit2892455bad3c99d183d731b6a52d3d64dbfe13e3 (patch)
tree832f7be5b18ff0aa8a84b3e96da1845c5857192d /meta-oe
parent31edfae0e21e0c036b261e2178a76286c5ac9a5a (diff)
downloadmeta-openembedded-contrib-2892455bad3c99d183d731b6a52d3d64dbfe13e3.tar.gz
libhugetlbfs: not build obj32 for all 64b platforms
qemux86_64 has the same issue with powerpc64, set BUILDTYPE=NATIVEONLY as default Fix the below build issue for 64bit platforms: | fatal error: gnu/stubs-32.h: No such file or directory | # include <gnu/stubs-32.h> | ^ | compilation terminated. | make: *** [obj32/elflink.o] Error 1 Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 55d555b5f9..315863db75 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -28,8 +28,7 @@ LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
LIBHUGETLBFS_ARCH_powerpc = "ppc"
LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
-EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=2"
-EXTRA_OEMAKE_append_powerpc64 = " BUILDTYPE=NATIVEONLY"
+EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} BUILDTYPE=NATIVEONLY V=2"
PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"