aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-07-15 05:50:03 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:47 +0200
commit717fe1ff766f71f18a2d80f23baec39fb79117e2 (patch)
tree93482f761258e9fdae7e8d51e344e3565cc91481 /meta-oe
parent18ccf18ee4949b785e240d9f8f8983c6554dd4e9 (diff)
downloadmeta-openembedded-contrib-717fe1ff766f71f18a2d80f23baec39fb79117e2.tar.gz
memstat: add new recipe
memstat is a small proc-based utility designed to help the system administrator figure out what's consuming memory. Like ps, it lists all the processes, and how much private memory each is using. Unlike ps, it also lists all the shared objects (shared libraries and executables) that are in memory, and which processes are using those shared objects. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/memstat/memstat_1.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/memstat/memstat_1.0.bb b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
new file mode 100644
index 0000000000..825215372c
--- /dev/null
+++ b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Display virtual memory allocation"
+DESCRIPTION = "Lists all the processes, executables, and shared libraries \
+that are using up virtual memory. It's helpful to see how the shared memory \
+is used and which 'old' libs are loaded. \
+"
+HOMEPAGE = "http://memstattool.sourceforge.net/"
+SECTION = "devtool"
+
+LICENSE = "GPLv2"
+
+S = "${WORKDIR}/memstattool"
+
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb"
+
+SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462"
+SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94"
+
+do_install_append(){
+ install -d ${D}${bindir}
+ install -m 0755 memstat ${D}${bindir}
+ install -d ${D}${sysconfdir}
+ install -m 0755 memstat.conf ${D}${sysconfdir}
+ install -d ${D}${mandir}/man1
+ install -m 0644 memstat.1 ${D}${mandir}/man1
+ install -d ${D}${docdir}/${BPN}
+ install -m 0644 memstat-tutorial.txt ${D}${docdir}/${BPN}
+}