aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-07 11:54:47 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-07 17:43:44 -0800
commit5abd5bccd545ca9d9fe4ce0a664c6f8733afeeca (patch)
tree700489ccd9de375fd53f4ad652a059ddda9a2f00 /meta-oe
parent0c6c10873a449c9b9c54c157dc7fb00ea280c7a9 (diff)
downloadmeta-openembedded-contrib-5abd5bccd545ca9d9fe4ce0a664c6f8733afeeca.tar.gz
nodejs: allow use of system nghttp2
We can't enable this by default, though, as nghttp2 is in the meta-networking layer, which might not be enabled. At least this gives people a simple way to do so if they want. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index 4afe341f92..4013c6931e 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -55,6 +55,7 @@ PACKAGECONFIG ??= "ares icu libuv zlib"
PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
PACKAGECONFIG[libuv] = "--shared-libuv,,libuv"
+PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2"
PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi