aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 14:44:04 -0800
committerArmin Kuster <akuster808@gmail.com>2018-01-22 20:25:04 -0800
commit5a949972155346b1db173fbfac7e6601f69a34f3 (patch)
tree56df33869bb98a3ae01514a9b6dadba36189f77a /meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
parent240ed30ac7fc81183c700d1b703d233e33429980 (diff)
downloadmeta-openembedded-contrib-5a949972155346b1db173fbfac7e6601f69a34f3.tar.gz
libextutils-cppguess-perl: upgrade 0.09 -> 0.12
Changes: 0.12 Sat Oct 21 18:12:51 BST 2017 - Fix tests on 5.26 without '.' in @INC (kentfredric) 0.11 Thu Sep 10 13:12:17 MDT 2015 - Add leading whitespace to $cflags in _get_cflags (bulk88) 0.10 Tue Sep 08 21:15:30 MDT 2015 - Config's ccflags must always be used. (bulk88) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb')
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
new file mode 100644
index 0000000000..99df6f33ff
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
@@ -0,0 +1,37 @@
+SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
+DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
+compiler that is compatible with the C compiler that your perl was built \
+with. \
+It can generate the necessary options to the Module::Build constructor or \
+to ExtUtils::MakeMaker's WriteMakefile function."
+SECTION = "libs"
+
+HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
+SRC_URI[md5sum] = "28be49072585b25df87e54180f741a4d"
+SRC_URI[sha256sum] = "31c47b5b15e3e9fd5ae7b35881a0fffd26a2983b241e7e3a1bc340d6d446186b"
+
+S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
+
+inherit cpan
+
+do_install () {
+ cpan_do_install
+}
+
+RDEPENDS_${PN} = " libcapture-tiny-perl \
+ perl-module-scalar-util \
+ perl-module-io-file \
+ perl-module-extutils-makemaker \
+ perl-module-file-spec \
+ perl-module-exporter \
+ perl-module-carp \
+ perl-module-file-temp \
+ perl-module-lib \
+"
+
+BBCLASSEXTEND = "native"