aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-04-02 10:45:29 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-12 11:07:48 +0200
commit57a687bc554cc15de9fc6c17aec7a3ea9175abbd (patch)
treec1c150e6c163dc228b338242028a12958895ced3 /meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb
parent16b1a289b95541a29221e66b2d5b8489e0cffd98 (diff)
downloadmeta-openembedded-contrib-57a687bc554cc15de9fc6c17aec7a3ea9175abbd.tar.gz
libstrictures-perl: update to 2.000002
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb')
-rw-r--r--meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb
new file mode 100644
index 0000000000..11a6e50051
--- /dev/null
+++ b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000002.bb
@@ -0,0 +1,45 @@
+SUMMARY = "strictures - turn on strict and make all warnings fatal"
+DESCRIPTION = "I've been writing the equivalent of this module at the top \
+of my code for about a year now. I figured it was time to make it shorter. \
+\
+Things like the importer in \"use Moose\" don't help me because they turn \
+warnings on but don't make them fatal -- which from my point of view is \
+useless because I want an exception to tell me my code isn't warnings-clean. \
+\
+Any time I see a warning from my code, that indicates a mistake. \
+\
+Any time my code encounters a mistake, I want a crash -- not spew to STDERR \
+and then unknown (and probably undesired) subsequent behaviour. \
+\
+I also want to ensure that obvious coding mistakes, like indirect object \
+syntax (and not so obvious mistakes that cause things to accidentally compile \
+as such) get caught, but not at the cost of an XS dependency and not at the \
+cost of blowing things up on another machine. \
+\
+Therefore, \"strictures\" turns on additional checking, but only when it \
+thinks it's running in a test file in a VCS checkout -- although if this \
+causes undesired behaviour this can be overridden by setting the \
+PERL_STRICTURES_EXTRA environment variable."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://metacpan.org/pod/strictures"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=246;endline=262;md5=43be558cf4f19823cdd6af22135cf5f8"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/strictures-${PV}.tar.gz"
+SRC_URI[md5sum] = "fb1fada8260992bc85e126c21ffcc6d5"
+SRC_URI[sha256sum] = "130355dcb3afd8c3c8213c24b924e71deb7e1e1197da8f90c5ae191766aa4100"
+
+S = "${WORKDIR}/strictures-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-carp \
+ perl-module-strict \
+ perl-module-test-more \
+ perl-module-warnings \
+"
+
+BBCLASSEXTEND = "native"