aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2015-11-07 16:21:25 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 10:46:55 +0100
commit0b7a554cbb0baa2c23dd3048f9d84ad95a84fd48 (patch)
treeead2aa9ca56b78a6410a26911af5fd15ee450310 /meta-perl
parent8be88d3249a8a49f1fda46890494e68499eed1c2 (diff)
downloadmeta-openembedded-contrib-0b7a554cbb0baa2c23dd3048f9d84ad95a84fd48.tar.gz
libmodule-build-perl: add 0.31
[Description from CPAN] `Module::Build' is a system for building, testing, and installing Perl modules. It is meant to be an alternative to `ExtUtils::MakeMaker'. Developers may alter the behavior of the module through subclassing in a much more straightforward way than with `MakeMaker'. It also does not require a `make' on your system - most of the `Module::Build' code is pure-perl and written in a very cross-platform way. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb
new file mode 100644
index 0000000000..c0fa06d08e
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build"
+DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
+Makefile.PL file to drive distribution configuration, build, test and \
+installation. Traditionally, Build.PL uses Module::Build as the underlying \
+build system. This module provides a simple, lightweight, drop-in replacement. \
+Whereas Module::Build has over 6,700 lines of code; this module has less than \
+120, yet supports the features needed by most distributions."
+SECTION = "libs"
+
+HOMEPAGE = "http://search.cpan.org/~kwilliams/Module-Build-0.31/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=43339d8f9d3a956ee9eceb07717ee95e"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/K/KW/KWILLIAMS/Module-Build-${PV}.tar.gz"
+SRC_URI[md5sum] = "3d4fdffe58f6236253767e5a71edf29b"
+SRC_URI[sha256sum] = "e2f723be8d6c70b4ddbca3b5e32e52e6e98eae8f43e34d7ede87efcb1796bbb5"
+
+S = "${WORKDIR}/Module-Build-${PV}"
+
+inherit cpan_build
+
+do_install () {
+ cpan_build_do_install
+}
+
+BBCLASSEXTEND = "native"