aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-07-30 10:19:27 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-01 14:23:46 +0200
commit9ee63821708901d535b87d28042b512bd1a67eca (patch)
tree2a4ac8cf40e3681433d2a9620011cc20426e2760 /meta-perl
parent0e9aae3e6b058670f47523861a2375e736f17321 (diff)
downloadmeta-openembedded-contrib-9ee63821708901d535b87d28042b512bd1a67eca.tar.gz
libxml-filter-buffertext-perl: add recipe
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-filter-buffertext-perl_1.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-filter-buffertext-perl_1.01.bb b/meta-perl/recipes-perl/libxml/libxml-filter-buffertext-perl_1.01.bb
new file mode 100644
index 0000000000..77dd616bfc
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-filter-buffertext-perl_1.01.bb
@@ -0,0 +1,25 @@
+SUMMARY = "XML::Filter::BufferText - Filter to put all characters() in one event"
+DESCRIPTION = "\
+The XML::Filter::BufferText module is a very simple filter. One common \
+cause of grief (and programmer error) is that XML parsers aren't required \
+to provide character events in one chunk. They can, but are not forced \
+to, and most don't. This filter does the trivial but oft-repeated task \
+of putting all characters into a single event. \
+"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPLv1+"
+HOMEPAGE = "http://search.cpan.org/dist/XML-Filter-BufferText/"
+DEPENDS += "libxml-sax-perl-native"
+RDEPENDS_${PN} += "libxml-sax-perl"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RB/RBERJON/XML-Filter-BufferText-${PV}.tar.gz"
+SRC_URI[md5sum] = "2992c0387632583b966ab9c965b25512"
+SRC_URI[sha256sum] = "8fd2126d3beec554df852919f4739e689202cbba6a17506e9b66ea165841a75c"
+
+LIC_FILES_CHKSUM = "file://BufferText.pm;beginline=88;endline=90;md5=497aa6d79cc84c3d769a2a0016bee928"
+
+S = "${WORKDIR}/XML-Filter-BufferText-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"