aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-08-27 22:01:31 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-01 11:37:12 +0200
commit6b881ba6fd3e828021c266d3bd9c7a606d120858 (patch)
tree5582a642080c6020a6967f0c0575da18d969feeb /meta-perl
parentaca94301c8b38a86ab4e851da0ba0007680ea75b (diff)
downloadmeta-openembedded-contrib-6b881ba6fd3e828021c266d3bd9c7a606d120858.tar.gz
libmodule-pluggable-perl: add 5.1
* Module::Pluggable - automatically give your module the ability to have plugins Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb
new file mode 100644
index 0000000000..b916918070
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Automatically give your module the ability to have plugins"
+DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
+having 'plugins' for your module. Obviously this isn't going to be the \
+be all and end all of solutions but it works for me.\
+\
+Essentially all it does is export a method into your namespace that \
+looks through a search path for .pm files and turn those into class \
+names.\
+\
+Optionally it instantiates those classes for you."
+SECTION = "libs"
+
+AUTHOR = "Simon Wistow <simon@thegestalt.org>"
+HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
+
+SRCNAME = "Module-Pluggable"
+SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "1b71ed7a67ad8c048d1499540bc892ba"
+SRC_URI[sha256sum] = "e2dc354043bb16f1f3df8c4bb26070b26e594819f218cf8b8ac19e79c720916f"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan_build
+
+RDEPENDS_${PN} = " perl-module-base \
+ perl-module-deprecate \
+ perl-module-file-basename \
+ perl-module-file-find \
+ perl-module-file-spec \
+ perl-module-file-spec-functions \
+ perl-module-if \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"
+