aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-19 10:03:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:44 +0000
commit7d1def8fba235fe8ccd32aab8cd96618f20c8111 (patch)
treeea4b68c4eee8d654006bda307edda5a7598d85eb /meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb
parent8d96e46f7c141ab2b632169037d06beca17e5d0b (diff)
downloadmeta-openembedded-contrib-7d1def8fba235fe8ccd32aab8cd96618f20c8111.tar.gz
python-cmd2: update to version 0.7.7
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb b/meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb
new file mode 100644
index 0000000000..fa1ef5f929
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cmd2_0.7.7.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=49;endline=49;md5=0f13c9cfc75288223cf7edd2f3b985a2"
+
+SRC_URI[md5sum] = "576b78add6d652b48dcf9362cece88ef"
+SRC_URI[sha256sum] = "b4e2fb9fc656adccc4d01dfd55ab5a9b05890e961950543f692e7885725c2d72"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-textutils \
+ "