aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-15 15:20:46 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:25 +0200
commit3c208853183758ec08bc3771c108981338d88b70 (patch)
tree643583543ffbd74b5ef8b5949bbe4711f3834c43 /meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb
parent7cf433a523b6179e27c80785a0ed62bf81553add (diff)
downloadmeta-openembedded-contrib-3c208853183758ec08bc3771c108981338d88b70.tar.gz
python-jsonpatch: update to version 1.14
* Use inspect.signature() Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb
new file mode 100644
index 0000000000..bc64ffcf03
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.14.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "cf4fbad8188f1389363433dbf867109f"
+SRC_URI[sha256sum] = "776d828d6f7b4581862529cf413439a652d74b9e3a0261fa08c36fd761a78b4a"
+
+RDEPENDS_${PN} += "python-re python-json python-jsonpointer"
+