aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-09 17:47:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:31 +0200
commitd0513b1d6137168a69f93c0eb84fbe77ccfd0145 (patch)
treefac41cf7369b81e0833111f6a491e27e70738285 /meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
parentc15782ebe5bf342d3328572c28d00788df9ea095 (diff)
downloadmeta-openembedded-contrib-d0513b1d6137168a69f93c0eb84fbe77ccfd0145.tar.gz
meta-python: Add Protobuf and gRPC Python recipes
Add recipes for Python PIP packages for Google's Protobuf, gRPC and gRPC tools. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
new file mode 100644
index 0000000000..61b8fef002
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Protocol Buffers"
+HOMEPAGE = "https://developers.google.com/protocol-buffers/"
+SECTION = "devel/python"
+
+RDEPENDS_${PN} = "python-six"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "27941e8e42e83d5183605054576882dd"
+SRC_URI[sha256sum] = "1cbcee2c45773f57cb6de7ee0eceb97f92b9b69c0178305509b162c0160c1f04"
+
+# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native"