aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest.inc
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-06 09:10:13 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-15 17:29:40 +0000
commit8e1de3aa5a70f6230e23f1d2dffd9183935894ee (patch)
tree73b7576955b841db60a4e5d59b6736ebdb0c958b /meta-python/recipes-devtools/python/python-pytest.inc
parent929a6543e617fc5cfd99069c1c390a6a15f093ce (diff)
downloadmeta-openembedded-contrib-8e1de3aa5a70f6230e23f1d2dffd9183935894ee.tar.gz
python-pytest: fix egg version of package
commit "python-pytest: remove fetch during do_compile phase" removed the ability of the package to version it self correctly. The version ended up as 0.0.0 which causes runtime version checking. This fixed that issues. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index ae1d81d171..6140250cac 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4"
SRC_URI[md5sum] = "401c005bd57f71e63ba015ab086fe67d"
SRC_URI[sha256sum] = "f46e49e0340a532764991c498244a60e3a37d7424a532b3ff1a6a7653f1a403a"
-SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch"
+SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
+ file://pytest_version_fix.patch "
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-argparse \