aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyudev.inc
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-05-26 03:37:31 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:47 +0200
commitab2ca92e8322549aa3f13af0c903aa80bd6f10ad (patch)
treeae3995da31c010210facb675f5b09d051aaaa0ba /meta-python/recipes-devtools/python/python-pyudev.inc
parentabc5a71c4d216742dc2af4b475136262ac169612 (diff)
downloadmeta-openembedded-contrib-ab2ca92e8322549aa3f13af0c903aa80bd6f10ad.tar.gz
python3-pyudev: add a python3 recipe
- Split to a common python-pyudev.inc for python2 and python3 - The contextlib module is moved to python3-lang. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyudev.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-pyudev.inc19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev.inc b/meta-python/recipes-devtools/python/python-pyudev.inc
new file mode 100644
index 0000000000..ab4c5fd7d5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyudev.inc
@@ -0,0 +1,19 @@
+SUMMARY = "A libudev binding"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b"
+SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b"
+
+do_configure_prepend() {
+ sed -i "/import pyudev/d" ${S}/setup.py
+ sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
+}
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+"