aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@gmail.com>2018-05-10 09:12:24 +1000
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:23:24 -0700
commitf90318b625a90993c4e20c981201602e37f89481 (patch)
treef4a9dbb98d490c403266ffe0ef4305df87351a07 /meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
parent676b1771438d1b71e95165102a625b40fb4d17fb (diff)
downloadmeta-openembedded-contrib-f90318b625a90993c4e20c981201602e37f89481.tar.gz
python-robotframework: Add runtime dependencies to robot framework
Add the runtime dependencies robot framework has so they are available on images including it. python-robotframework.inc is included by both python3 and python robot framework. python3 includes zlib by default so include python-zlib as a runtime dependency in the python-robotframework recipe and not in the python3-robotframework. Signed-off-by: Sipke Vriend <sipke.vriend@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
index 16eaa78cdb..ff7dedb559 100644
--- a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-robotframework.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-zlib \
+"