aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-02-23 19:34:37 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-28 12:34:14 +0100
commit4b5baed4c7b1cb5ff77acf9bc19d007fa4308b24 (patch)
tree44c35af52fffb85ea90833e3a63389e9531e776d /meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb
parent2e9b8c63afaed04818c00a8b7bfbbd577a211c37 (diff)
downloadmeta-openembedded-contrib-4b5baed4c7b1cb5ff77acf9bc19d007fa4308b24.tar.gz
python-slip-dbus: update to version 0.6.1
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb
new file mode 100644
index 0000000000..785cecc358
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Convenience functions for dbus services in Python 2.x"
+HOMEPAGE = "http://nphilipp.fedorapeople.org/python-slip/"
+DESCRIPTION = "\
+The Simple Library for Python 2.x packages contain miscellaneous code for \
+convenience, extension and workaround purposes. \
+\
+This package provides slip.dbus.service.Object, which is a dbus.service.Object \
+derivative that ends itself after a certain time without being used and/or if \
+there are no clients anymore on the message bus, as well as convenience \
+functions and decorators for integrating a dbus service with PolicyKit."
+
+SECTION = "devel/python"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
+SRCNAME = "python-slip"
+
+SRC_URI = "https://fedorahosted.org/released/${SRCNAME}/${SRCNAME}-${PV}.tar.bz2"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+SRC_URI[md5sum] = "a6d8ee96245fc21785d4c1c062c85f2f"
+SRC_URI[sha256sum] = "bc897f1ab6f5b4989f85548799aaeb84fde67bbba18e40341bfe1d7885c2fd9a"
+
+do_compile_prepend() {
+ sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
+}