aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-10 08:48:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:35 +0200
commitbc892fb0cd52d1c3c7c5b1417d94a0e3f580f60e (patch)
tree3ef996a634a3197308fd607fa1358b2a92d71bc1 /meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
parent045d79e0b221028fb783b14a27e0c02b329c4026 (diff)
downloadmeta-openembedded-contrib-bc892fb0cd52d1c3c7c5b1417d94a0e3f580f60e.tar.gz
python-vcversioner: update to version 2.16.0.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
new file mode 100644
index 0000000000..9308c12afb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python vcversioner, automagically update the project's version"
+HOMEPAGE = "https://github.com/habnabit/vcversioner"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=827a7a91a8d20d3c666b665cd96db8e3"
+
+SRC_URI[md5sum] = "aab6ef5e0cf8614a1b1140ed5b7f107d"
+SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa06e19b"
+
+inherit pypi setuptools
+
+do_compile_append() {
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+
+do_install_append() {
+ install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}
+
+BBCLASSEXTEND = "native"