aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 19:55:10 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 23:02:39 -0800
commit6b9db4343afbd611179ab2d10e19970d32fc8ed8 (patch)
tree63e33467f439059733bcd09e2eb3e0506169ccb0 /meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
parent04cd18f1d986daa3e7b9802e55d33d03429db4d6 (diff)
downloadmeta-openembedded-contrib-6b9db4343afbd611179ab2d10e19970d32fc8ed8.tar.gz
python3-automat: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-automat_0.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-automat_0.8.0.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb b/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
index 2c747643ff..f8981bcb19 100644
--- a/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
@@ -1,2 +1,21 @@
-inherit setuptools3
-require python-automat.inc
+DESCRIPTION = "Self-service finite-state machines for the programmer on the go"
+HOMEPAGE = "https://github.com/glyph/Automat"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+
+SRC_URI[md5sum] = "47e980a48201a1dabe37fa11f0187013"
+SRC_URI[sha256sum] = "269a09dfb063a3b078983f4976d83f0a0d3e6e7aaf8e27d8df1095e09dc4a484"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+SRC_URI_append = " \
+ file://0001-setup.py-remove-the-dependency-on-m2r.patch \
+"
+
+PYPI_PACKAGE = "Automat"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-six \
+"