aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 13:57:24 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit48c61dfe2385f6d3af78a8542d5ad30ed6c2f789 (patch)
treef0771862b2130648aaa1423555264444e4366cd9 /meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
parent747b6bd61f20bb782ad5c38066893038717c35a7 (diff)
downloadmeta-openembedded-contrib-48c61dfe2385f6d3af78a8542d5ad30ed6c2f789.tar.gz
python3-behave: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-behave_1.2.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-behave_1.2.6.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
index 1c55871b10..a28e527315 100644
--- a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
+++ b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb
@@ -1,2 +1,15 @@
-inherit setuptools3
-require python-behave.inc
+SUMMARY = "A behavior-driven development framework, Python style"
+HOMEPAGE = "https://github.com/behave/behave"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
+
+SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d"
+SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-parse-type \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+ "