aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 14:44:14 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitabc2a8515ab94befa75813937a68e86579d2c32b (patch)
tree0624ce06520e1fed8db2b0afd03eadfa3a0c2345 /meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
parent587a2ba4f1f3060d6164d81bc3e9c2f94e7d5219 (diff)
downloadmeta-openembedded-contrib-abc2a8515ab94befa75813937a68e86579d2c32b.tar.gz
python3-booleanpy: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
index 5f8602d187..ebf7ba4e74 100644
--- a/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
+++ b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
@@ -1,2 +1,14 @@
-inherit setuptools3
-require python-booleanpy.inc
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"