aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2019-11-29 12:52:02 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-30 00:13:55 -0800
commit448a5be9a3c95a6c944e43768d183d9433d36038 (patch)
tree721a8105eee724632599c23176f409242965c8cd /meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
parentae88e8ce9c1dc2dbd4b40fac05f68d6fb03885b0 (diff)
downloadmeta-openembedded-contrib-448a5be9a3c95a6c944e43768d183d9433d36038.tar.gz
python3-dbussy: add recipe (v1.2.1)
Pure python dbus library with support for various loop including asyncio >From the readme: DBussy allows you to take advantage of asyncio, but it doesn’t force you to use it. DBussy is meant to give you access to (nearly) all the functionality of the underlying libdbus library <https://dbus.freedesktop.org/doc/api/html/index.html>. libdbus is a very low-level, very general library, designed to be called from C code, that makes no assumptions about event loops at all. Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb b/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
new file mode 100644
index 0000000000..ac4b8c2aa6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "language bindings for libdbus, for Python 3.5 or later"
+HOMEPAGE = "https://github.com/ldo/dbussy"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+SRC_URI = "git://github.com/ldo/dbussy.git"
+
+SRCREV = "d0ec0223f3797e1612d835e71694a1083881149f"
+
+S = "${WORKDIR}/git"
+
+inherit distutils3
+
+RDEPENDS_${PN} += "\
+ python3-asyncio \
+ python3-core \
+ python3-ctypes \
+ python3-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+