aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:39 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commitbde96455036076de7803b7b9e617e24f0e2c1a11 (patch)
treeb4a1dadefb0f74814d23cf229f09ce9480fc3c1d /meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb
parent87980b86bcc3528f16550d790083a24ad29682a1 (diff)
downloadmeta-openembedded-contrib-bde96455036076de7803b7b9e617e24f0e2c1a11.tar.gz
python3-mpmath: add recipe for 1.10
This is a dependency for python3-sympy. This recipe is adapted from one in meta-jupyter, which is also MIT-licensed. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb b/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb
new file mode 100644
index 0000000000..7879a85cdd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb
@@ -0,0 +1,16 @@
+# This recipe is adapted from one in meta-jupyter:
+# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-mpmath_0.19.bb
+
+SUMMARY = "Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE = "https://pypi.org/project/mpmath/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=efe9feb00df0b763941f2b1bbac7c402"
+
+SRC_URI[md5sum] = "acb1cdddf38e16084628065b174ddbfe"
+SRC_URI[sha256sum] = "fc17abe05fbab3382b61a123c398508183406fa132e0223874578e20946499f6"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-image"
+
+BBCLASSEXTEND = "native nativesdk"