aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-16 17:12:30 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-17 08:11:16 -0700
commit26a6ddc70b12e90b9791dddf57225a5b7d99ccb7 (patch)
tree25424882877460ecf200e4e4bf6d776a7b5ef7eb /meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb
parent77c992785c546a5783c13954839d6a85a2709abc (diff)
downloadmeta-openembedded-contrib-26a6ddc70b12e90b9791dddf57225a5b7d99ccb7.tar.gz
python3-ujson: Upgrade 4.0.2 -> 4.1.0
Upgrade to release 4.1.0: - Add gcov coverage testing for C code - Test Python 3.10-dev - Remove explicit handling of manylinux platform tag - Remove unused variable - dconv no longer uses global instances of StringToDoubleConverter - Switch shebang for the manylinux-wheels script - Fix typos in error message Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb b/meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb
new file mode 100644
index 0000000000..d8e83c58a1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_4.1.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
+
+SRC_URI[sha256sum] = "22b63ec4409f0d2f2c4c9d5aa331997e02470b7a15a3233f3cc32f2f9b92d58c"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytz \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"