aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-01 13:36:56 -0400
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:31 -0800
commit865d7c09b89e487b95051a6154c234b2421e9429 (patch)
treed077ee74f59daad9e5815cfd6d61af15760b3829 /meta-python/recipes-devtools/python
parente410b5c54373ce9539f2df9840e3d987f319ee6c (diff)
downloadmeta-openembedded-contrib-865d7c09b89e487b95051a6154c234b2421e9429.tar.gz
python-snimpy: refactor to use pypi class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb b/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb
index cbdc6bd86f..e0747b7a17 100644
--- a/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb
+++ b/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb
@@ -3,21 +3,15 @@ DESCRIPTION = "Snimpy is a Python-based tool providing a simple interface to bui
HOMEPAGE = "https://pypi.python.org/pypi/snimpy"
SECTION = "devel/python"
-DEPENDS = "libsmi python-cffi-native python-vcversioner-native"
+DEPENDS += "libsmi python-cffi-native python-vcversioner-native"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://docs/license.rst;md5=7c53ab2d1240828625c3e093d049d4f4"
-SRCNAME = "snimpy"
-
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
SRC_URI[md5sum] = "7f6270ce2e7206df165602e66d5ceb96"
SRC_URI[sha256sum] = "10410614c7bff1053ca65bd760ce919f1a074f4988b857df4c57cf35847922b0"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+inherit pypi setuptools
RDEPENDS_${PN} = "python-cffi \
python-pycparser \